System Requirements

Last Updated: Aug 12, 2017
Pokki's web store works in Firefox 32+, Safari 5+, Internet Explorer 10+, and Google Chrome.

The Pokki Start Menu and App Store currently support Windows 7, Windows 8, and Windows 8.1.

 
help@pokki.com
http://assets0.desk.com/
@Pokki
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
Invalid characters found
/customer/en/portal/articles/autocomplete